# Generated from slots-jwt-0.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name slots-jwt

Name: rubygem-%{gem_name}
Version: 0.1.1
Release: 1%{?dist}
Summary: Token Authentication for Rails using JWT
License: MIT
URL: https://github.com/jonathongardner/slots-jwt
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(sqlite3)
BuildArch: noarch

%description
Token Authentication for Rails using JWT. Slots is designed to keep JWT
stateless and minimize database calls. This is done by storing (none
sensitive) data in the JWT and populating current_user with the JWT data. This
allows for things like `current_user.teams` or other assocations to be called
on the user. Unless explicitly told slots will only load the user from the
database when creating (or updating an expired) token.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/MIT-LICENSE
%{gem_instdir}/app
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile

%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.1-1
- Initial package