# Generated from termgui-0.0.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name termgui

Name: rubygem-%{gem_name}
Version: 0.0.6
Release: 1%{?dist}
Summary: Pure Ruby library for building amazing interactive command line interfaces
License: MIT
URL: https://github.com/cancerberoSgx/termgui
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
* Pure Ruby library for creating desktop-like interfaces in the command line.
* Flexible and easy to use utilities for focus/actions/scroll/events/cursor.
* Support high level APIs similar to HTML DOM APIs like layouts, styles,
box-model, cascade styles, XML/ERB, boxes, fonts, images, colors, easing,
* Low level utilities can be used independently without bloating the
performance
* Event loop supporting set_timeout, wait_for, set_interval
* Many high level widgets, utilities implemented expected in GUIs.
* WIP (my first Ruby project)
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE
%{gem_instdir}/TODO.md
%{gem_libdir}
%{gem_instdir}/src
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/test

%changelog
* Thu Sep 16 2021 mockbuilder - 0.0.6-1
- Initial package