# Generated from user_stamp-4.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name user_stamp

Name: rubygem-%{gem_name}
Version: 4.0.0
Release: 1%{?dist}
Summary: Provides the ability to stamp database records with the user name/id/email when creating, updating or destroying
License: MIT
URL: https://www.github.com/mjpete3/user_stamp
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.7
# BuildRequires: rubygem(sqlite3)
BuildArch: noarch

%description
Preserve the user identity when database records are updated for tracking or
audit purposes.You can configure which field (:id, :email, :login_name) from
the current_user object to track.  The gem uses the current_user object from
Devise. Users are required to be authenticated to the application.For RAILS
3.2.x use gem version 3.x,  For RAILS 4.x.x use gem version 4.x.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/MIT-LICENSE
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile
%{gem_instdir}/test

%changelog
* Thu Sep 16 2021 mockbuilder - 4.0.0-1
- Initial package