# Generated from grntest-1.7.7.gem by gem2rpm -*- rpm-spec -*-
%global gem_name grntest

Name: rubygem-%{gem_name}
Version: 1.7.7
Release: 1%{?dist}
Summary: Grntest is a testing framework for Groonga. You can write a test for Groonga by writing Groonga commands and expected result
License: GPL-3.0+
URL: https://github.com/groonga/grntest
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(kramdown)
# BuildRequires: rubygem(packnga)
# BuildRequires: rubygem(test-unit) >= 3.0.0
# BuildRequires: rubygem(test-unit-rr)
BuildArch: noarch

%description
Grntest is a testing framework for Groonga. You can write a test for Groonga
by writing Groonga commands and expected result.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{_bindir}/grntest
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/doc
%{gem_instdir}/grntest.gemspec
%{gem_instdir}/test

%changelog
* Tue Nov 12 2024 mockbuilder - 1.7.7-1
- Initial package