# Generated from generate_dump_file-0.1.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name generate_dump_file

Name: rubygem-%{gem_name}
Version: 0.1.2
Release: 1%{?dist}
Summary: Create dump file in temporary directoy
License: techracers
URL: https://github.com/jainnimish7/generate_dump_file
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
Create dump file in temporary folder of root directory, if folder not present
in dir then it will create one. 
Usage: open interactive prompt by typing 'irb' and require
'generate_dump_file'.
again, require File.expand_path('../config/environment', __FILE__) and then
run GenerateDumpFile.create .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/generate_dump_file.gemspec

%changelog
* Mon Sep 13 2021 mockbuilder - 0.1.2-1
- Initial package