# Generated from pretty_inspect-1.4.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pretty_inspect

Name: rubygem-%{gem_name}
Version: 1.4.0
Release: 1%{?dist}
Summary: Pretty Inspect (pretty_inspect) is an extension to Object::inspect
License: Ruby
URL: http://rubygems.org/gems/pretty_inspect
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Pretty Inspect can be used anywhere Object::inspect can be used, and produces
a more human readable representation of the object.
It can be called as:
object.pretty_inspect
object.pretty_inspect(n), where n is the maximum depth to display.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Tue Sep 14 2021 mockbuilder - 1.4.0-1
- Initial package