# Generated from sloth-rb-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sloth-rb

Name: rubygem-%{gem_name}
Version: 0.1.0
Release: 1%{?dist}
Summary: Sloth gives you a mess of handy functions that will help you avoid writing these useful code snippets by hand
License: MIT
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.2
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
Sloth is a collection of helpers. A whole bunch of methods defind on ruby's
inbuilt classes, just so you can code away without taking the pain of writing
it by yourself. Sloth was born out of boredom. The need to write same code
snippets over and over again. If you would like to add a method/helper that
you think would be useful to others as well, please do send a pull request.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/sloth.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.0-1
- Initial package