# Generated from amun-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name amun

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: Emacs like editor, with Ruby core instead of ELisp
License: MIT
URL: http://www.github.com/blazeeboy/amun
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(guard)
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(rspec-its)
# BuildRequires: rubygem(guard-rspec)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(codeclimate-test-reporter) >= 1.0.0
# BuildRequires: rubygem(codeclimate-test-reporter) < 1.1
BuildArch: noarch

%description
A CLI editor built to have an Emacs similar development environment, with ruby
in the heart of it instead of Elisp, that will make developing plugins and
extensions faster and more enjoyable, this editor is kept to the minimum,
anything that could be written as an pluging will be found as a plugin.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/amun
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.rubocop.yml
%{gem_instdir}/.ruby-version
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/_config.yml
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/amun.gemspec

%changelog
* Sun Sep 12 2021 mockbuilder - 0.2.0-1
- Initial package