# Generated from crossing-0.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name crossing

Name: rubygem-%{gem_name}
Version: 0.2.1
Release: 1%{?dist}
Summary: Utility for storing objects in S3 while taking advantage of client side envelope encryption with KMS
License: MIT
URL: http://www.stelligent.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.5
# BuildRequires: rubygem(cucumber)
# BuildRequires: rubygem(nyan-cat-formatter)
# BuildRequires: rubygem(rubocop)
# BuildRequires: rubygem(rubygems-tasks)
# BuildRequires: rubygem(simplecov)
BuildArch: noarch

%description
The native AWS command line does not have an easy way to upload encrypted
files
to S3. The Ruby SDK has a way to do this, but not everyone wants to use it.
This utility allows you to do client side encrypted uploads to S3 from the
command line, which is useful for uploads from your CI system to docker
containers.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# cucumber
popd

%files
%dir %{gem_instdir}
%{_bindir}/crossing
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Mon Sep 13 2021 mockbuilder - 0.2.1-1
- Initial package