# Generated from metafy-1.0.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name metafy

Name: rubygem-%{gem_name}
Version: 1.0.3
Release: 1%{?dist}
Summary: Dynamic Attributes Engine for Rails 3
License: MIT
URL: http://blairwilliams.com/ruby-on-rails/metafy
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Metafy is a Gem for Rails 3 that makes it possible to easily add dynamic
attributes to any ActiveRecord model. These lightweight, meta attributes work
just like normal database column attributes on your ActiveRecord model and are
fully searchable (i.e. you can find records by values contained in these
dynamic attributes).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/MIT-LICENSE
%{gem_instdir}/app
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile
%{gem_instdir}/metafy.gemspec
%{gem_instdir}/test

%changelog
* Tue Sep 14 2021 mockbuilder - 1.0.3-1
- Initial package