# Generated from opt_ar-1.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name opt_ar

Name: rubygem-%{gem_name}
Version: 1.1.0
Release: 1%{?dist}
Summary: Generates memory-friendly and immutable read-optimized ActiveRecord dupes for caching and other purposes
License: MIT
URL: https://github.com/ragav0102/opt_ar
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest) >= 5.0
# BuildRequires: rubygem(minitest) < 6
BuildArch: noarch

%description
Generates memory-optimal immutable ActiveRecord dupes that are easily
serializable and behaves much like ARs. Define required attributes before-hand
and use them just as you would on an AR, for better memory optimization.
Ideally, suitable in place of caching AR objects with cache stores like
Memcached, where serialization and de-serialization are memory-hungry. Optars
can save upto 90% of your memory(object allocations), while being upto 20x
faster, when fetching huge AR results.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.circleci
%{gem_instdir}/.coveralls.yml
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/benchmarks
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/opt_ar.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 1.1.0-1
- Initial package