# Generated from pco_api-2.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pco_api

Name: rubygem-%{gem_name}
Version: 2.0.0
Release: 1%{?dist}
Summary: API wrapper for api.planningcenteronline.com
License: MIT
URL: https://github.com/planningcenter/pco_api_ruby
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.0.0
# BuildRequires: rubygem(rspec) >= 3.2
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(webmock) >= 1.21
# BuildRequires: rubygem(webmock) < 2
# BuildRequires: rubygem(pry) >= 0.10
# BuildRequires: rubygem(pry) < 1
BuildArch: noarch

%description
pco_api is a gem for working with the RESTful JSON API at
api.planningcenteronline.com using HTTP basic auth or OAuth 2.0. This library
can talk to any endpoint the API provides, since it is written to build
endpoint URLs dynamically using method_missing.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/spec

%changelog
* Tue Sep 14 2021 mockbuilder - 2.0.0-1
- Initial package