# Generated from rtanque-0.1.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rtanque

Name: rubygem-%{gem_name}
Version: 0.1.3
Release: 1%{?dist}
Summary: RTanque is a game for programmers. Players program the brain of a tank and then send their tank into battle against other tanks
License: MIT
URL: https://github.com/awilliams/RTanque
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(rspec) >= 3.7.0
# BuildRequires: rubygem(rspec) < 3.8
BuildArch: noarch

%description
RTanque is a game for programmers. Players program the brain of a tank and
then send their tank+brain into battle with other tanks. All tanks are
otherwise equal.
Rules of the game are simple: Last bot standing wins. Gameplay is also pretty
simple. Each tank has a base, turret and radar, each of which rotate
independently. The base moves the tank, the turret has a gun mounted to it
which can fire at other tanks, and the radar detects other tanks in its field
of vision.
Have fun competing against friends' tanks or the sample ones included. Maybe
you'll start a small league at your local Ruby meetup.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/rtanque
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-gemset
%{gem_instdir}/.ruby-version
%exclude %{gem_instdir}/.travis.yml
%exclude %{gem_instdir}/.yardopts
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/resources
%{gem_instdir}/sample_bots
%{gem_instdir}/screenshots
%{gem_instdir}/templates
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.ci
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/rtanque.gemspec
%{gem_instdir}/spec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.3-1
- Initial package