# Generated from sqs-grep-0.1.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sqs-grep

Name: rubygem-%{gem_name}
Version: 0.1.4
Release: 1%{?dist}
Summary: Find messages on an SQS queue by regular expression, and optionally delete them
License: Apache-2.0
URL: https://github.com/rvedotrc/sqs-grep
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
sqs-grep iterates through each message on the given SQS queue, testing its
body against the given regular expression, displaying matching messages to
standard output.
Options are available to control match inversion, json output, deletion of
matching messages, match limits, sending the messages to another queue,
and timeouts.
Respects $https_proxy.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/sqs-grep
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.4-1
- Initial package