# Generated from kojac-0.17.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name kojac

Name: rubygem-%{gem_name}
Version: 0.17.0
Release: 1%{?dist}
Summary: KOJAC is an opinionated design and implementation for data management within Single Page Applications
License: MIT
URL: https://github.com/buzzware/KOJAC
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec)
BuildArch: noarch

%description
KOJAC is an opinionated design and implementation for data management within
Single Page Applications. It relates most heavily to the client and data
protocol. The server may continue the key/value style down to a
key/value-style database if desired, but that is not necessary. KOJAC also
supports standard REST-style servers.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/MIT-LICENSE
%{gem_instdir}/app
%{gem_instdir}/diagram.odg
%{gem_libdir}
%{gem_instdir}/notes.txt
%{gem_instdir}/vendor
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/kojac.gemspec
%{gem_instdir}/spec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.17.0-1
- Initial package