# Generated from r2-oas-0.5.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name r2-oas

Name: rubygem-%{gem_name}
Version: 0.5.0
Release: 1%{?dist}
Summary: Provide rake tasks to management API Docment (OpenAPI)
License: MIT
URL: https://github.com/yukihirop/r2-oas
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.5.0
# BuildRequires: rubygem(coveralls)
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rubocop)
# BuildRequires: rubygem(appraisal)
# BuildRequires: rubygem(activerecord) >= 4.2.5
BuildArch: noarch

%description
== Let's intuitively write API documentation with Swagger Editor in your Rails
Project! 😊
Configureless and no DSL. 👍 But you can also configure.  
Manage with yaml file instead of Ruby code.  
Loosely coupled to your Rails project. 👍  
So if you want to use another tool, you can port it right away. 😢  
Generate api docment(OpenAPI) side only from `Rails` routing.  
Provide rake tasks to management API Docment (OpenAPI) 🎉  
$ bundle exec rake routes:oas:init
$ bundle exec rake routes:oas:docs
$ bundle exec rake routes:oas:ui
$ bundle exec rake routes:oas:editor
$ bundle exec rake routes:oas:monitor
$ bundle exec rake routes:oas:build
$ bundle exec rake routes:oas:clean
$ bundle exec rake routes:oas:analyze
$ bundle exec rake routes:oas:deploy
Happy Coding ❗️.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/GEMSPEC.md
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%doc %{gem_instdir}/README.ja.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/r2-oas.gemspec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.5.0-1
- Initial package