# Generated from special-0.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name special

Name: rubygem-%{gem_name}
Version: 0.0.1
Release: 1%{?dist}
Summary: Experiment with type-specialized container classes in Ruby
License: MIT
URL: https://github.com/ms-ati/special
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3
BuildArch: noarch

%description
Experiment with a protocol for specifying and implementing specializations of
Ruby container classes, both standard and user defined, for more efficient
execution in cases of homogenous and/or frozen elements.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}

%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Wed Aug 25 2021 mockbuilder - 0.0.1-1
- Initial package