# Generated from thimble-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name thimble

Name: rubygem-%{gem_name}
Version: 0.1.0
Release: 1%{?dist}
Summary: Concurrency and Parallelism gem that uses blocks to move data
License: MIT
URL: https://github.com/akovanda/thimble
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Thimble is a ruby gem for parallelism and concurrency. It allows you to decide
if you want to use separate processes, or if you want to use threads in ruby.
It allows you to create stages with a thread safe queue, and break apart large
chunks of work.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Wed Aug 25 2021 mockbuilder - 0.1.0-1
- Initial package