# Generated from util-0.4.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name util

Name: rubygem-%{gem_name}
Version: 0.4.0
Release: 1%{?dist}
Summary: Collection of simple utilities to reduce boilerplate
License: CECILL-C
URL: https://gitlab.com/guillel/util-gem
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
A collection of diverse simple utilities without much anything to do
with one another. The main rationale is to reduce the time spent on
boilerplate like checking whether the arguments have the right type,
or introducing some basic internationalization. More detail in the README.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/CECILL-C.EN
%{gem_instdir}/CECILL-C.FR
%license %{gem_instdir}/LICENSES.md
%{gem_libdir}
%{gem_instdir}/share
%{gem_instdir}/tools
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/test

%changelog
* Wed Aug 25 2021 mockbuilder - 0.4.0-1
- Initial package