# Generated from vixen-0.0.12.gem by gem2rpm -*- rpm-spec -*-
%global gem_name vixen

Name: rubygem-%{gem_name}
Version: 0.0.12
Release: 1%{?dist}
Summary: Ruby bindings for VMware VIX API
License: Apache-2 and MIT
URL: https://github.com/jeffweiss/vixen
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.8.7
BuildArch: noarch

%description
Vixen is an easy way to interact with VMware virtual machines from Ruby. 
Vixen is not affliated with or endorsed by VMware.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/vixen
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE
%license %{gem_instdir}/MIT.LICENSE
%{gem_instdir}/bin
%{gem_instdir}/ext
%{gem_libdir}
%{gem_instdir}/vixen-example.rb
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/vixen.gemspec

%changelog
* Wed Aug 25 2021 mockbuilder - 0.0.12-1
- Initial package