# Generated from arli-1.4.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name arli

Name: rubygem-%{gem_name}
Version: 1.4.0
Release: 1%{?dist}
Summary: This is an Arduino helper toolkit that builds on top of the arduino-cmake project — a powerful alternative build system for Arduino. What Arli provides is capability to search for libraries by any attributes and regular expressions, install a whole set of libraries defined in a YAML file Arlifile, and finally, it can generate a brand new Sketch Project based on arduino-cmake, that builds out the box. Arli is a command line tool, so run "arli" after installing the gem for more information
License: MIT
URL: https://github.com/kigster/arli
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(aruba)
# BuildRequires: rubygem(rspec) >= 3
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rspec-its)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(yard)
BuildArch: noarch

%description
This is an Arduino helper toolkit that builds on top of the arduino-cmake
project — a powerful alternative build system for Arduino. What Arli provides
is capability to search for libraries by any attributes and regular
expressions,
install a whole set of libraries defined in a YAML file Arlifile, and finally,
it can generate a brand new Sketch Project based on arduino-cmake, that builds
out the box. Arli is a command line tool, so run "arli" after installing the
gem
for more information.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/arli
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/arli.gemspec
%doc %{gem_instdir}/docs

%changelog
* Sun Sep 12 2021 mockbuilder - 1.4.0-1
- Initial package