# Generated from credere-0.10.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name credere

Name: rubygem-%{gem_name}
Version: 0.10.3
Release: 1%{?dist}
Summary: A Plugin providing a Double Entry Accounting Engine for Rails
License: MIT
URL: http://github.com/ercubed/credere
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 1.3.6
BuildRequires: ruby
# BuildRequires: rubygem(yard)
BuildArch: noarch

%description
The Credere plugin provides a complete double entry accounting system for use
in any Ruby on Rails application. The plugin follows general Double Entry
Bookkeeping practices. All calculations are done using BigDecimal in order to
prevent floating point rounding errors. The plugin requires a decimal type on
your database as well. It is strongly based off of the Plutus gem.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE
%{gem_instdir}/app
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.markdown
%{gem_instdir}/Rakefile
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 0.10.3-1
- Initial package