# Generated from dnsmadeeasy-0.4.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dnsmadeeasy
Name: rubygem-%{gem_name}
Version: 0.4.0
Release: 1%{?dist}
Summary: This is an authoratative and fully-featured API client for the DNS Provider "DnsMadeEasy.com". This library offers both a rich Ruby API that you can use to automate DNS record management, as well as a rich CLI interface with the command line executable "dme" installed when you install the gem. The gem additionally supports storing credentials in the ~/.dnsmadeeasy/credentials.yml file, supports multiple accounts, encryption, and more. If you are using Chef consider using the "dnsmadeeasy" Chef Cookbook, while uses this gem behind the scenes: https://supermarket.chef.io/cookbooks/dnsmadeeasy
ACKNOWLEDGEMENTS: 1. This gem is based on the original work contributed by Wanelo.com to the now abandonded "dnsmadeeasy-rest-api" client. 2. We also wish to thank the gem author Phil Cohen who kindly yielded the "dnsmadeeasy" RubyGems namespace to this gem. 3. We also thank Praneeth Are for contributing the support for secondary domains in 0.3.5
License: MIT
URL: https://github.com/kigster/dnsmadeeasy
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(relaxed-rubocop)
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(rspec-its)
# BuildRequires: rubygem(rubocop)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(webmock)
# BuildRequires: rubygem(yard)
BuildArch: noarch
%description
This is an authoratative and fully-featured API client for the DNS Provider
"DnsMadeEasy.com".
This library offers both a rich Ruby API that you can use to automate DNS
record management, as well
as a rich CLI interface with the command line executable "dme" installed when
you install the gem.
The gem additionally supports storing credentials in the
~/.dnsmadeeasy/credentials.yml
file, supports multiple accounts, encryption, and more.
If you are using Chef consider using the "dnsmadeeasy" Chef Cookbook, while
uses this gem behind
the scenes: https://supermarket.chef.io/cookbooks/dnsmadeeasy
ACKNOWLEDGEMENTS:
1. This gem is based on the original work contributed by Wanelo.com to the
now abandonded "dnsmadeeasy-rest-api" client.
2. We also wish to thank the gem author Phil Cohen who
kindly yielded the "dnsmadeeasy" RubyGems namespace to this gem.
3. We also thank Praneeth Are for contributing the support for secondary
domains in 0.3.5.
%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description doc
Documentation for %{name}.
%prep
%setup -q -n %{gem_name}-%{version}
%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec
# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install
%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
%{buildroot}%{gem_dir}/
mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
%{buildroot}%{_bindir}/
find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x
%check
pushd .%{gem_instdir}
# rspec spec
popd
%files
%dir %{gem_instdir}
%{_bindir}/dme
%{gem_instdir}/.codeclimate.yml
%{gem_instdir}/.dme-help.png
%{gem_instdir}/.github
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.rubocop.yml
%exclude %{gem_instdir}/.rubocop_todo.yml
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.adoc
%{gem_instdir}/Rakefile
%{gem_instdir}/dnsmadeeasy.gemspec
%changelog
* Mon Sep 13 2021 mockbuilder - 0.4.0-1
- Initial package