# Generated from ElasticEmail-4.0.13.gem by gem2rpm -*- rpm-spec -*-
%global gem_name ElasticEmail
Name: rubygem-%{gem_name}
Version: 4.0.13
Release: 1%{?dist}
Summary: Elastic Email REST API Ruby Gem
License: Unlicense
URL: https://elasticemail.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.4
# BuildRequires: rubygem(rspec) >= 3.6
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rspec) >= 3.6.0
BuildArch: noarch
%description
This API is based on the REST API architecture, allowing the user to easily
manage their data with this resource-based approach. Every API call is
established on which specific request type (GET, POST, PUT, DELETE) will be
used. The API has a limit of 20 concurrent connections and a hard timeout
of 600 seconds per request. To start using this API, you will need your
Access Token (available here).
Remember to keep it safe. Required access levels are listed in the given
request’s description. This is the documentation for REST API. If you’d
like to read our legacy documentation regarding Web API v2 click here.
Downloadable library clients can be found in our Github repository here.
%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description doc
Documentation for %{name}.
%prep
%setup -q -n %{gem_name}-%{version}
%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec
# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install
%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
%{buildroot}%{gem_dir}/
%check
pushd .%{gem_instdir}
# rspec spec
popd
%files
%dir %{gem_instdir}
%{gem_instdir}/VERSION
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
%files doc
%doc %{gem_docdir}
%{gem_instdir}/ElasticEmail.gemspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/docs
%{gem_instdir}/spec
%changelog
* Mon Sep 13 2021 mockbuilder - 4.0.13-1
- Initial package