# Generated from giturl-1.3.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name giturl

Name: rubygem-%{gem_name}
Version: 1.3.2
Release: 1%{?dist}
Summary: Show or open GitHub URL for your local directory
License: MIT
URL: https://github.com/shinyaohtani/giturl/blob/master/README.md
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3.0
# BuildRequires: rubygem(github_changelog_generator) >= 1.15.0
# BuildRequires: rubygem(pry) >= 0.12.2
# BuildRequires: rubygem(pry-byebug) >= 3.9.0
# BuildRequires: rubygem(rspec) >= 3.9.0
# BuildRequires: rubygem(rubocop) >= 0.80.1
# BuildRequires: rubygem(rubocop-performance) >= 1.5.2
# BuildRequires: rubygem(rubocop-rspec) >= 1.38.1
BuildArch: noarch

%description
A tiny helper for accessing GitHub web pages corresponding to local
working directories.
Have you ever wanted to access a GitHub web page while working on
a git-cloned local directory?
You can use 'giturl' to display the URL corresponding to the git-managed
directory given as an argument. And furthermore, if you want to access
the URL immediately with your browser, 'giturl' opens your browser and
automatically accesses the URL without your any operation on the browser.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/giturl
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.rubocop.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/giturl.gemspec

%changelog
* Mon Sep 13 2021 mockbuilder - 1.3.2-1
- Initial package