# Generated from HDLRuby-2.6.10.gem by gem2rpm -*- rpm-spec -*-
%global gem_name HDLRuby

Name: rubygem-%{gem_name}
Version: 2.6.10
Release: 1%{?dist}
Summary: HDLRuby is a library for describing and simulating digital electronic systems
License: MIT
URL: https://github.com/civol/HDLRuby
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.0
BuildArch: noarch

%description
HDLRuby is a library for describing and simulating digital electronic systems.
With this library it will possible to describe synthesizable hardware using
all the features of the Ruby language, e.g., object orientation, duck typing,
closure. This library is also usable through irb for interactive design and
simulation.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/hdrcc
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%exclude %{gem_instdir}/.yardopts
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%{gem_instdir}/metadata.yaml
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/HDLRuby.gemspec
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/README.pdf
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/makedoc

%changelog
* Mon Sep 13 2021 mockbuilder - 2.6.10-1
- Initial package