# Generated from httplog-1.5.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name httplog

Name: rubygem-%{gem_name}
Version: 1.5.0
Release: 1%{?dist}
Summary: Log outgoing HTTP requests
License: MIT
URL: http://github.com/trusche/httplog
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.2
# BuildRequires: rubygem(ethon) >= 0.11
# BuildRequires: rubygem(ethon) < 1
# BuildRequires: rubygem(excon) >= 0.60
# BuildRequires: rubygem(excon) < 1
# BuildRequires: rubygem(faraday) >= 1.3
# BuildRequires: rubygem(faraday) < 2
# BuildRequires: rubygem(guard-rspec) >= 4.7
# BuildRequires: rubygem(guard-rspec) < 5
# BuildRequires: rubygem(http) >= 4.0
# BuildRequires: rubygem(http) < 5
# BuildRequires: rubygem(httparty) >= 0.16
# BuildRequires: rubygem(httparty) < 1
# BuildRequires: rubygem(httpclient) >= 2.8
# BuildRequires: rubygem(httpclient) < 3
# BuildRequires: rubygem(rest-client) >= 2.0
# BuildRequires: rubygem(rest-client) < 3
# BuildRequires: rubygem(listen) >= 3.0
# BuildRequires: rubygem(listen) < 4
# BuildRequires: rubygem(patron) >= 0.12
# BuildRequires: rubygem(patron) < 1
# BuildRequires: rubygem(rspec) >= 3.7
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(simplecov) >= 0.15
# BuildRequires: rubygem(simplecov) < 1
# BuildRequires: rubygem(thin) >= 1.7
# BuildRequires: rubygem(thin) < 2
# BuildRequires: rubygem(oj) >= 3.9.2
BuildArch: noarch

%description
Log outgoing HTTP requests made from your application. Helpful for tracking
API calls
of third party gems that don't provide their own log output.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/httplog.gemspec

%changelog
* Mon Sep 13 2021 mockbuilder - 1.5.0-1
- Initial package