# Generated from insite-0.2.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name insite

Name: rubygem-%{gem_name}
Version: 0.2.6
Release: 1%{?dist}
Summary: Page object library with an emphasis on simplified navigation and reusable code. It has features geared towards supporting web components (www.webcomponents.org) or any recurring feature in your application. UI automation components that you define are extensions of the DOM and are fully interopable with standard DOM elements and other components
License: MIT
URL: https://github.com/jfitisoff/insite
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3.0
# BuildRequires: rubygem(coveralls) >= 0.8.21
# BuildRequires: rubygem(simplecov) >= 0.16.1
# BuildRequires: rubygem(pry) >= 0.11.3
# BuildRequires: rubygem(rspec) >= 3.7.0
BuildArch: noarch

%description
Page object library with an emphasis on simplified navigation and reusable
code.
It has features geared towards supporting web components
(www.webcomponents.org)
or any recurring feature in your application. UI automation components that
you
define are extensions of the DOM and are fully interopable with standard DOM
elements and other components.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Mon Sep 13 2021 mockbuilder - 0.2.6-1
- Initial package