# Generated from minitar-0.9.gem by gem2rpm -*- rpm-spec -*-
%global gem_name minitar

Name: rubygem-%{gem_name}
Version: 0.9
Release: 1%{?dist}
Summary: The minitar library is a pure-Ruby library that provides the ability to deal with POSIX tar(1) archive files
License: Ruby and BSD-2-Clause
URL: https://github.com/halostatue/minitar/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.8
# BuildRequires: rubygem(minitest) >= 5.11
# BuildRequires: rubygem(minitest) < 6
# BuildRequires: rubygem(hoe-doofus) >= 1.0
# BuildRequires: rubygem(hoe-doofus) < 2
# BuildRequires: rubygem(hoe-gemspec2) >= 1.1
# BuildRequires: rubygem(hoe-gemspec2) < 2
# BuildRequires: rubygem(hoe-git) >= 1.6
# BuildRequires: rubygem(hoe-git) < 2
# BuildRequires: rubygem(hoe-rubygems) >= 1.0
# BuildRequires: rubygem(hoe-rubygems) < 2
# BuildRequires: rubygem(hoe-travis) >= 1.2
# BuildRequires: rubygem(hoe-travis) < 2
# BuildRequires: rubygem(minitest-autotest) >= 1.0
# BuildRequires: rubygem(minitest-autotest) < 2
# BuildRequires: rubygem(hoe) >= 3.18
# BuildRequires: rubygem(hoe) < 4
BuildArch: noarch

%description
The minitar library is a pure-Ruby library that provides the ability to deal
with POSIX tar(1) archive files.
This is release 0.9, adding a minor feature to Minitar.unpack and
Minitar::Input#extract_entry that when <tt>:fsync => false</tt> is provided,
fsync will be skipped.
minitar (previously called Archive::Tar::Minitar) is based heavily on code
originally written by Mauricio Julio Fernández Pradier for the rpa-base
project.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/Code-of-Conduct.md
%license %{gem_instdir}/Licence.md
%{gem_instdir}/Manifest.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/Contributing.md
%doc %{gem_instdir}/History.md
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/docs
%{gem_instdir}/test

%changelog
* Tue Sep 14 2021 mockbuilder - 0.9-1
- Initial package