# Generated from pa_api-0.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pa_api

Name: rubygem-%{gem_name}
Version: 0.0.1
Release: 1%{?dist}
Summary: A simple wrapper for the Parallels Automation APIs
License: MIT
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
# PaApi
A simple wrapper for the Parallels Automation APIs.
## Installation
Add this line to your application's Gemfile:
```ruby
gem 'pa_api'
```
And then execute:
$ bundle
Or install it yourself as:
$ gem install pa_api
## Usage
Just use the damn thing already.
## Contributing
1. Fork it ( https://github.com/[my-github-username]/pa_api/fork )
2. Create your feature branch (`git checkout -b my-new-feature`)
3. Commit your changes (`git commit -am 'Add some feature'`)
4. Push to the branch (`git push origin my-new-feature`)
5. Create a new Pull Request.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/pa_api.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.0.1-1
- Initial package