# Generated from pygmy-0.9.11.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pygmy

Name: rubygem-%{gem_name}
Version: 0.9.11
Release: 1%{?dist}
Summary: pygmy provides the required servies to run the amazee.io Drupal local development environment on linux
License: MIT
URL: https://github.com/amazeeio/pygmy
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.4
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(byebug) >= 8.2
# BuildRequires: rubygem(byebug) < 9
# BuildRequires: rubygem(codeclimate-test-reporter) >= 0.5
# BuildRequires: rubygem(codeclimate-test-reporter) < 1
BuildArch: noarch

%description
To fully and easy run a local Drupal development system you need more then
just a docker container with the Drupal running. Default development workflows
involves running multiple sites at the same time, interacting with other
services which are authenticated via ssh and more.Pygmy makes usre that the
required Docker containers are started and that youcomfortably can access the
Drupal Containers just via the browser.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/pygmy
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Tue Sep 14 2021 mockbuilder - 0.9.11-1
- Initial package