# Generated from rlang-0.5.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rlang

Name: rubygem-%{gem_name}
Version: 0.5.1
Release: 1%{?dist}
Summary: A (subset of) Ruby to WebAssembly compiler
License: MPL-2.0
URL: https://github.com/ljulliar/rlang
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest) >= 5.0
# BuildRequires: rubygem(minitest) < 6
# BuildRequires: rubygem(wasmer) >= 0.3
# BuildRequires: rubygem(wasmer) < 1
# BuildRequires: rubygem(simplecov) >= 0.18
# BuildRequires: rubygem(simplecov) < 1
BuildArch: noarch

%description
Rlang is meant to create fast and uncluttered WebAssembly code 
from the comfort of the Ruby language. It is actually made of two things: a
supported 
subset of the Ruby language and a compiler transforming this Ruby subset in a
valid 
and fully runnable WebAssembly module.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{_bindir}/rlang
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/docs
%{gem_instdir}/examples
%{gem_instdir}/rlang.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.5.1-1
- Initial package