# Generated from safedb-0.10.17.gem by gem2rpm -*- rpm-spec -*-
%global gem_name safedb

Name: rubygem-%{gem_name}
Version: 0.10.17
Release: 1%{?dist}
Summary: safe locks and unlocks secrets in a simple, secure and intuitive way
License: MIT
URL: https://www.safedb.net
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.5.1
BuildArch: noarch

%description
safe is a credentials manager for the linux command line written in Ruby. It
locks and unlocks secrets in a safe simple and intuitive manner. You can then
visit websites, manufacture keys and passwords, inject credentials into
Jenkins, and interact with many tools including S3, GoogleDrive, Terraform,
Git and Docker.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/safe
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/Jenkinsfile
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/pkg
%{gem_instdir}/pod-image-validate.yaml
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CONTRIBUTING.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/git-release.sh
%doc %{gem_instdir}/pod-image-release.yaml
%{gem_instdir}/safedb.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.10.17-1
- Initial package