# Generated from slacked-0.9.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name slacked

Name: rubygem-%{gem_name}
Version: 0.9.2
Release: 1%{?dist}
Summary: A super simple and easy way to send notifications to Slack from your Rails application
License: MIT
URL: https://github.com/codelittinc/slacked
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(rspec-mocks)
BuildArch: noarch

%description
This is a super simple Slack integration for Rails. A use case for this would
be to post
a notification in Slack when a new User is created or a certain action has
been taken in
your application.
Are there other gems that provide similar functionality? Yes. Do some of them
provide more
flexibility? Yes. The point of this was to make installing and integrating a
30 second process.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/slacked.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.9.2-1
- Initial package