# Generated from srfax-0.5.5.gem by gem2rpm -*- rpm-spec -*-
%global gem_name srfax

Name: rubygem-%{gem_name}
Version: 0.5.5
Release: 1%{?dist}
Summary: SR Fax Module provides and easy way to access SR fax online services to send, receive or query faxes
License: MIT
URL: https://github.com/bouchard/srfax
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest)
# BuildRequires: rubygem(pry) >= 0.8
# BuildRequires: rubygem(pry) < 1
# BuildRequires: rubygem(yard) >= 0.8
# BuildRequires: rubygem(yard) < 1
BuildArch: noarch

%description
This is the 'unofficial' SRFax (http://www.srfax.com) API wrapper for ruby. 
The API documentation for SRFax can be found at
https://www.srfax.com/srf/media/SRFax-REST-API-Documentation.pdf.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/srfax.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.5.5-1
- Initial package