# Generated from tracco-0.0.20.gem by gem2rpm -*- rpm-spec -*-
%global gem_name tracco

Name: rubygem-%{gem_name}
Version: 0.0.20
Release: 1%{?dist}
Summary: You notify all the estimates and efforts of your Trello cards. This tool will extract and store these estimates and actual efforts to let you extract useful key metrics (e.g. estimate errors)
License: BSD
URL: http://xplayer.github.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 1.3.6
BuildRequires: ruby
# BuildRequires: rubygem(awesome_print)
# BuildRequires: rubygem(debugger)
BuildArch: noarch

%description
Tracco is a Trello effort tracker: the purpose of Tracco is to extract and
track estimates and actual efforts out of the cards on your Trello boards.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/tracco
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-version.template
%{gem_instdir}/.rvmrc.template
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/config
%{gem_instdir}/images
%{gem_libdir}
%{gem_instdir}/script
%{gem_instdir}/tracco.sublime-project
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%doc %{gem_instdir}/CHANGELOG
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec
%{gem_instdir}/tracco.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 0.0.20-1
- Initial package