# Generated from treemap-1.0.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name treemap

Name: rubygem-%{gem_name}
Version: 1.0.3
Release: 1%{?dist}
Summary: TreeMap is a Ruby port of the Android implementation of Java's java.util.TreeMap class
License: MIT
URL: https://github.com/davidkellis/treemap
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
A Ruby port of the Android implementation of Java's java.util.TreeMap
class.
This is an AVL tree based implementation of Java's java.util.TreeMap
structure.
It implements Java's java.util.NavigableMap interface.
The reference implementation is at
https://android.googlesource.com/platform/libcore.git/+/android-6.0.1_r32/luni/src/main/java/java/util/TreeMap.java.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Thu Sep 16 2021 mockbuilder - 1.0.3-1
- Initial package