# Generated from tweep-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name tweep

Name: rubygem-%{gem_name}
Version: 0.1.0
Release: 1%{?dist}
Summary: Automatic Twitter Peeping
License: MIT
URL: http://github.com/tdd/tweep
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(twitter) >= 2.0.2
# BuildRequires: rubygem(twitter) < 2.1
BuildArch: noarch

%description
Tweep lets you rotate through tweets in a scheduled manner, with multiple
accounts, and auto-retweet such tweets on other accounts yet.  For instance,
think recent accounts for product launches versus their more established
company accounts.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/tweep
%license %{gem_instdir}/MIT-LICENSE.txt
%{gem_instdir}/accounts
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.markdown
%doc %{gem_instdir}/README.markdown

%changelog
* Thu Sep 16 2021 mockbuilder - 0.1.0-1
- Initial package