# Generated from uspec-1.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name uspec

Name: rubygem-%{gem_name}
Version: 1.0.2
Release: 1%{?dist}
Summary: a shiny little spec framework for your apps!
License: MIT
URL: http://github.com/acook/uspec#readme
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.1
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(pry-doc)
BuildArch: noarch

%description
Uspec is a shiny little spec framework for your apps! Unlike other testing
frameworks there's no need for matchers, there can only be one assertion per
test, and you never have to worry that your tests lack assertions.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/uspec
%{gem_instdir}/.circleci
%{gem_instdir}/.editorconfig
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.rubocop.yml
%{gem_instdir}/.ruby-gemset
%{gem_instdir}/.ruby-version
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/example_specs
%{gem_libdir}
%{gem_instdir}/uspec
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.markdown
%{gem_instdir}/Rakefile
%{gem_instdir}/uspec.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 1.0.2-1
- Initial package