# Generated from walk_up-1.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name walk_up

Name: rubygem-%{gem_name}
Version: 1.0.2
Release: 1%{?dist}
Summary: A simple library to walk up a folder path
License: MIT
URL: https://github.com/jeff-hykin/walk_up.git
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.5.0
BuildArch: noarch

%description
A simple function for walking up a file directory until a certain file
is found.
```ruby
require "walk_up"
require_relative walk_up_until("globals.rb") # <- will keep looking in parent
directories for a "globals.rb" file
```.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE.md
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Thu Sep 16 2021 mockbuilder - 1.0.2-1
- Initial package