# Generated from xipio-1.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name xipio

Name: rubygem-%{gem_name}
Version: 1.0.2
Release: 1%{?dist}
Summary: Add xip.io support to your rails app in development mode
License: MIT
URL: https://github.com/fphilipe/xipio
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
When reading the subdomain of an xip.io request, you will get a different
value
compared to a local pow request. The reason for this is that the tld length is
1 by default, but an xip.io request has a tld length of 6. This gem inserts a
middleware that corrects the tld length config of rails on the fly so that you
can use local and xip requests at the same time without restarting the server.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/xipio.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 1.0.2-1
- Initial package