# Generated from awsudo-2.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name awsudo

Name: rubygem-%{gem_name}
Version: 2.0.0
Release: 1%{?dist}
Summary: executes a command with the permissions given by an AWS IAM role
License: BSD-3-Clause
URL: https://github.com/electronicarts/awsudo
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
awsudo enables users to execute commands that make API calls to AWS under the
security context of an IAM role. The IAM role is assumed only upon successful
authentication against a SAML compliant federation service.
aws-agent enables users to authenticate against a SAML compliant federation
service once, after which aws-agent provides temporary credentials to awsudo
to
use.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/awsudo
%{_bindir}/aws-agent
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%doc %{gem_instdir}/CONTRIBUTING.md
%doc %{gem_instdir}/README.md

%changelog
* Mon Apr 18 2022 mockbuilder - 2.0.0-1
- Initial package