# Generated from baal-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name baal

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: Baal is a Ruby wrapper for start-stop-daemon that attempts to make your start-stop-daemon scripts easier to build and read while still providing the same options you are used to. Baal, through start-stop-daemon, provides a myriad of ways to start new daemon processes and check the status of and stop existing ones
License: MIT
URL: https://github.com/numbluk/baal
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(pry) >= 3.0
# BuildRequires: rubygem(pry) < 4
BuildArch: noarch

%description
Baal is a Ruby wrapper for start-stop-daemon that attempts to make your
start-stop-daemon scripts easier to build and read while still providing the
same options you are used to. Baal, through start-stop-daemon, provides a
myriad of ways to start new daemon processes and check the status of and stop
existing ones.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/baal.gemspec

%changelog
* Mon Apr 18 2022 mockbuilder - 0.2.0-1
- Initial package