# Generated from be-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name be

Name: rubygem-%{gem_name}
Version: 0.1.0
Release: 1%{?dist}
Summary: Behavior Expressive
License: BSD-2-Clause
URL: http://rubyworks.github.com/be
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(detroit)
# BuildRequires: rubygem(spectroscope)
BuildArch: noarch

%description
Be (Behavioral expectations) is a fully versitle, light-weight and BRASS
compliant assertions framework for Ruby. It utilizes an *assertor* design
(*matchers* in RSpec terminology) which meshes well with BDD nomenclatures.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/License.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/History.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/spec

%changelog
* Mon Apr 18 2022 mockbuilder - 0.1.0-1
- Initial package