# Generated from boggler-0.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name boggler

Name: rubygem-%{gem_name}
Version: 0.0.1
Release: 1%{?dist}
Summary: Boggle as a gem
License: LGPLV3
URL: http://www.bitbucket.org/ToadJamb/gems_boggler
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(cane)
# BuildRequires: rubygem(rspec)
BuildArch: noarch

%description
Boggle as a gem.
It may be used to play a game (simply run boggler)
or watch it solve randomly generated grids (run boggler_solver).
See readme.md for additional details.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/boggler
%{_bindir}/boggler_solver
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/vendor
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/readme.md

%changelog
* Mon Apr 18 2022 mockbuilder - 0.0.1-1
- Initial package