# Generated from dolphin-0.1.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dolphin

Name: rubygem-%{gem_name}
Version: 0.1.6
Release: 1%{?dist}
Summary: Dolphin: deploy agilely like dolphins can swim. A multi-threaded multi-stage deployment tool utilizes the full power of Git and Ruby. * Bye bye, serial iteration over list of servers; * Welcome, multi-threaded deployment using Parallel gem. * Bye bye, afterthought of the multistage extension; * Welcome, multi-stage deployment built in from inception. * Bye bye, SVN style checkout directories on servers; * Welcome, git repository on servers. * Bye bye, Capistrano style symlink tricks for current / rollback; * Welcome, git checkout. * Bye bye, Rake tasks; * Welcome, Thor actions. * Bye bye, RVM; * Welcome, Chruby. * Bye bye, gemset; * Welcome, system wide gems. * Bye bye, complexity; * Welcome, nimbleness
License: MIT
URL: https://github.com/nengxu/dolphin
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Dolphin: deploy agilely like dolphins can swim. A multi-threaded multi-stage
deployment tool utilizes the full power of Git and Ruby.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/dolphin
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/dolphin.gemspec
%{gem_instdir}/spec

%changelog
* Mon Apr 18 2022 mockbuilder - 0.1.6-1
- Initial package