# Generated from funit-0.12.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name funit

Name: rubygem-%{gem_name}
Version: 0.12.4
Release: 1%{?dist}
Summary: funit is a unit testing framework for Fortran
License: NASA-1.3
URL: https://rubygems.org/gems/funit
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(hoe) >= 3.14
# BuildRequires: rubygem(hoe) < 4
BuildArch: noarch

%description
funit is a unit testing framework for Fortran.
Unit tests are written as Fortran fragments that use a small
set of testing-specific keywords and functions.  funit transforms
these fragments into valid Fortran code, compiles, links, and
runs them against the code under test.
funit is
{opinionated
software}[http://www.oreillynet.com/pub/a/network/2005/08/30/ruby-rails-david-heinemeier-hansson.html],
which values convention over configuration. Specifically, funit requires,
* a Fortran 95 compiler,
* tests to be stored along side the code under test, and
* test files to be named appropriately.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/funit
%license %{gem_instdir}/License.txt
%{gem_instdir}/Manifest.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/pitch
%{gem_instdir}/utils
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/History.rdoc
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile
%{gem_instdir}/examples
%{gem_instdir}/test

%changelog
* Tue Apr 19 2022 mockbuilder - 0.12.4-1
- Initial package