# Generated from gogyou-0.2.5.gem by gem2rpm -*- rpm-spec -*-
%global gem_name gogyou

Name: rubygem-%{gem_name}
Version: 0.2.5
Release: 1%{?dist}
Summary: binary data operation library with the C liked struct and union
License: 2-clause BSD License
URL: https://osdn.jp/projects/rutsubo/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.0
# BuildRequires: rubygem(rspec) >= 2.14
# BuildRequires: rubygem(rspec) < 3
BuildArch: noarch

%description
The gogyou is a library written at pure ruby that provides auxiliary features
of binary data operation for ruby.
The C-liked struct, union and multidimensional array definition are posible in
ruby syntax.
Available features:
(1) nested struct and union with anonymous field
(2) multidimensional array
(3) field of variable array
(4) const field
(5) packed field
(6) user definition types
(7) (EXPERIMENTAL AND LIMITATION FEATURE) pointer.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE
%{gem_instdir}/gemstub.rb
%{gem_libdir}
%{gem_instdir}/mkprims.rb
%{gem_instdir}/pointer.ja.md
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/HISTORY.ja.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec
%{gem_instdir}/test

%changelog
* Tue Apr 19 2022 mockbuilder - 0.2.5-1
- Initial package