# Generated from mod_10-0.0.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name mod_10

Name: rubygem-%{gem_name}
Version: 0.0.3
Release: 1%{?dist}
Summary: Generates mod10 check digits and checks if values already are valid mod10
License: MIT
URL: https://github.com/kryptykfysh/mod_10
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
# Mod10
A simple gem to generate mod_10 check digits and check if integers are mod10
valid.
## Installation
Add this line to your application's Gemfile:
```ruby
gem 'mod_10'
```
And then execute:
$ bundle
Or install it yourself as:
$ gem install mod_10
## Usage
Include the Mod10 module to make the following two methods available
- generate_check_digit(value)
Which returns an integer value for the mod10 check digit of a string or
integer.
Note: If the value is 0, then the argument was already mod10 valid.
- is_mod10?(value)
Returns true or false for the tested value is it is or isn't mod10 valid.
## Contributing
1. Fork it ( https://github.com/[my-github-username]/mod_10/fork )
2. Create your feature branch (`git checkout -b my-new-feature`)
3. Commit your changes (`git commit -am 'Add some feature'`)
4. Push to the branch (`git push origin my-new-feature`)
5. Create a new Pull Request.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-version
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%{gem_instdir}/mod_10-0.0.1.gem
%{gem_instdir}/mod_10-0.0.2.gem
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/mod_10.gemspec

%changelog
* Tue Apr 19 2022 mockbuilder - 0.0.3-1
- Initial package