# Generated from moft-1.0.5.gem by gem2rpm -*- rpm-spec -*-
%global gem_name moft

Name: rubygem-%{gem_name}
Version: 1.0.5
Release: 1%{?dist}
Summary: A simple, static site generator that is based off of Jekyll
License: MIT
URL: http://www.psikon.com/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(redgreen) >= 1.2
# BuildRequires: rubygem(redgreen) < 2
# BuildRequires: rubygem(shoulda) >= 3.3.2
# BuildRequires: rubygem(shoulda) < 3.4
# BuildRequires: rubygem(rr) >= 1.0
# BuildRequires: rubygem(rr) < 2
# BuildRequires: rubygem(cucumber) >= 1.2.1
# BuildRequires: rubygem(cucumber) < 1.3
# BuildRequires: rubygem(cucumber) < 1.2.4
# BuildRequires: rubygem(cucumber) > 1.2.4
# BuildRequires: rubygem(RedCloth) >= 4.2
# BuildRequires: rubygem(RedCloth) < 5
# BuildRequires: rubygem(rdiscount) >= 1.6
# BuildRequires: rubygem(rdiscount) < 2
# BuildRequires: rubygem(redcarpet) >= 2.2.2
# BuildRequires: rubygem(redcarpet) < 2.3
# BuildRequires: rubygem(launchy) >= 2.1.2
# BuildRequires: rubygem(launchy) < 2.2
# BuildRequires: rubygem(simplecov) >= 0.7
# BuildRequires: rubygem(simplecov) < 1
# BuildRequires: rubygem(simplecov-gem-adapter) >= 1.0.1
# BuildRequires: rubygem(simplecov-gem-adapter) < 1.1
BuildArch: noarch

%description
Moft is a simple, static site generator. A fork of jekyll, designed for
greater simplicity and less blog-related features.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# cucumber
popd

%files
%dir %{gem_instdir}
%{_bindir}/moft
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/moft.gemspec

%changelog
* Tue Apr 19 2022 mockbuilder - 1.0.5-1
- Initial package